EIGRP · IPv6 · Routing

EIGRP IPv6 map-leak

eigrp_ipv6_leak_map

!
hostname R1
!
ipv6 unicast-routing
!
interface Loopback1
  ipv6 address 2001:A:B:1000::1/64
  ipv6 enable
!
interface FastEthernet0/0
  ipv6 address 2001:A:B::2/127
  ipv6 enable
! 
interface FastEthernet1/0
  ipv6 address 2001:A:A:1000::2/127
  ipv6 enable
!
router eigrp CONFIG-IF
!
  address-family ipv6 unicast autonomous-system 65000
  !
  af-interface default
    passive-interface
  exit-af-interface
  !
  af-interface FastEthernet0/0
    no passive-interface
  exit-af-interface
  !
  af-interface FastEthernet1/0
    summary-address 2001:A:B::/48
    no passive-interface
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 1.1.1.1
  exit-address-family
!
!
hostname R2
!
ipv6 unicast-routing
!
interface Loopback1
  ipv6 address 2001:A:B:2000::1/64
  ipv6 enable
!
interface Loopback2
  ipv6 address 2001:A:B:3000::1/64
  ipv6 enable
!
interface FastEthernet0/0
  ipv6 address 2001:A:B::3/127
  ipv6 enable
!
interface FastEthernet1/0
  ipv6 address 2001:A:A:1000::4/127
  ipv6 enable
!
router eigrp CONFIG-IF
!
  address-family ipv6 unicast autonomous-system 65000
  !
  af-interface default
    passive-interface
  exit-af-interface
  !
  af-interface FastEthernet0/0
    no passive-interface
  exit-af-interface
  !
  af-interface FastEthernet1/0
    summary-address 2001:A:B::/48
    no passive-interface
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 2.2.2.2
  exit-address-family
!

 

!
hostname R3
!
ipv6 unicast-routing
!
interface FastEthernet0/0
  ipv6 address 2001:A:A:1000::3/127
  ipv6 enable
!
interface FastEthernet0/1
  ipv6 address 2001:A:A:1000::5/127
  ipv6 enable
!
router eigrp CONFIG-IF
!
address-family ipv6 unicast autonomous-system 65000
!
  topology base
  exit-af-topology
  eigrp router-id 3.3.3.3
  eigrp stub receive-only
  exit-address-family
!
R3#sh ipv6 route eigrp 
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
D 2001:A:B::/48 [90/103040]
   via FE80::C801:1EFF:FE8B:1C, FastEthernet0/0
   via FE80::C802:1EFF:FE9A:1C, FastEthernet0/1

Now add the leak-map:

!
hostname R2
!
router eigrp CONFIG-IF
!
address-family ipv6 unicast autonomous-system 65000
!
  af-interface FastEthernet1/0
    summary-address 2001:A:B::/48 leak-map R2_LEAK_MAP
  exit-af-interface
  !
!
route-map R2_LEAK_MAP permit 10
  match ipv6 address R2_PREFIX_LEAK
!
ipv6 access-list R2_PREFIX_LEAK
  permit ipv6 2001:A:B:3000::/64 any
!
R3#sh ipv6 route eigrp 
IPv6 Routing Table - default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
D 2001:A:B::/48 [90/103040]
   via FE80::C801:1EFF:FE8B:1C, FastEthernet0/0
   via FE80::C802:1EFF:FE9A:1C, FastEthernet0/1
D 2001:A:B:3000::/64 [90/103040]
   via FE80::C802:1EFF:FE9A:1C, FastEthernet0/1
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s